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   How to Use MovieCaptioner 
Please take a few minutes to familiarize yourself with these instructions 
before starting to work with MovieCaptioner. In addition to these 
instructions, there are helpful videos on the website at 

http://www.synchrimedia.com/tutorials.html that will help you with creating captions, 
editing your captions, and outputting your captions and transcripts. The link is also 
available under the Help menu. 
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Requirements (somewhat dependent upon the type of files you create) 

•  Mac OSX 10.5 or newer and QuickTime 7 must be installed (available from your 
Snow Leopard install disk or from the Apple Web site). 

• QuickTime Pro version 7 or better is required for using the QuickTime Player option 
for embedded captions, including Embedded QT, Embedded QT (Unicode), and Sonic 
Scenarist (Embed in QT). QT Pro is not required for any of the other export formats. 
Snow Leopard users must make sure that QuickTime 7 is installed along with 
QuickTime X (which is the default movie player in Snow Leopard). QuickTime 7 is 
available from the Snow Leopard install disk or from the Apple Web site. 

• ClosedCaptionImporter.component plug-in for QuickTime (available from Apple) for 
embedding SCC format closed captions. It can also be downloaded from the 
MovieCaptioner Web site at http://www.synchrimedia.com/ClosedCaptionImporter.zip. 
This is useful for previewing SCC captions. To add SCC captions to a movie you should 
either use Subler (free from http://code.google.com/p/subler/) or Compressor ($49.95 
from Apple http://www.apple.com/finalcutpro/compressor/). 

• Adobe Flash CS3 or newer required for creating captioned Flash videos 
(MovieCaptioner can make the XML file even if you do not have Flash).  

• Perian plug-in (free from http://www.perian.org/) required if you want to load Flash FLV 
movies into the movie window to create captions.  

• Flip4Mac plug-in (free from http://www.telestream.net/flip4mac-wmv/overview.htm) 
required to load Windows Media movies to make SAMI captions.  
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Getting Started 

 
Start by clicking on the Load Movie button. Browse your computer to find your 
movie. After loading your movie, you will be prompted to save your caption 
project. This is so that the automatic save feature can work properly and you 
won't need to remember to save your work. This could save you a lot of rework. 
Each time you enter a caption and either hit the Return key or the Save Caption 
button, MovieCaptioner will automatically save your project. It will also save after 
editing a caption, or if you remove a caption using the Remove Caption button. 
Just make sure that when you save it initially you retain the ".mcpt" extension on 
the project file. That way you can double-click it to launch your project. 

Please note that MovieCaptioner may make your movie aspect ratio look a bit off 
because it squashes it into a 320x240 player window. This is to maximize the 
caption interface space. This will not affect your movie at all. It will keep the same 
aspect ratio in the final version. In fact, MovieCaptioner will never change your 
original movie, unless you embed captions and save the changes in QuickTime 
Pro. 

After the movie is loaded and you've saved your project, the text area will then 
become active for editing. You will not be able to add text until a movie is loaded. 
Click the Start button to start adding captions. Do not use the movie's play 
button! The movie's play button is there mostly to review the movie or if you 
need to skip over longer segments of the movie than the Repeat Interval allows.  

It is best to set the frames per second rate of your movie in the MovieCaptioner 
Preferences window. This is the export setting for formats such as SCC that may 
use the frame rate to calculate timecode properly. The export frame rate is 

displayed between the 
movie player window and 
the caption list. 

Clicking this number will 
open the Preferences 
window where it can be 
changed easily. 
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The Start/Stop Button 

After you click the Start button, the first 4 seconds (or 
whatever you have set in the Repeat Interval control) will 
begin repeating over and over until you type in what is 
being said and either hit the Return key (preferred method) 
or click the Save Caption button. It will then go to the next 
four seconds (or whatever it's set to) and begin repeating 

that snippet. You will hear an audible Beep at the end of each loop to signify 
where the loop ends. The Beep can be turned off by unchecking the Beep on 
checkbox. If your movie will start out without a caption in the beginning, or at any 
point in the movie where nothing is being spoken, you can hit the Return key or 
click the Save Caption button to save a blank text field for that section. Setting a 
blank caption is also a good idea if there is an extended period of time when no 
words are spoken. That way the previous caption will not stay on too long.  

As you type, the built in live spell check 
will highlight misspelled words in an 
alternate color than that which you have 
your text color set to. Please note that it 
will only check a word when it sees that 
you are done typing it either by some 
punctuation or a space. So, if you are 
unsure of the spelling of the last word 
prior to hitting the Return key (or Save 
button), type a space after that word to 
allow it to check.  

f you find the repetition annoying, you can 
also start and stop the movie while adding 
captions by using the key combination 
CTRL+Spacebar. It will keep repeating 
while the Start button is on, but when 
Stop is clicked, CTRL+Spacebar will 

allow the movie to play through without looping. This might work similar to using 
a foot pedal for transcription. 

Always make sure the Spellcheck Dictionary is in the same folder as the 
MovieCaptioner application. If it’s not in the same folder it will keep asking you 
where it is when you open MovieCaptioner.  

 

 



	   6	  

Controlling the Repeat Interval 
The Repeat Interval controls how long the loop sequence will be. It can either be 
adjusted by clicking the arrows next to it or by the key shortcuts CNTRL+LEFT to 
decrement and CNTRL+RIGHT to increment the interval. 

If you see that your caption is running to three lines, reduce the Repeat Interval 
and retype the caption. Try to keep your captions to two lines at most for best 
readability. 

To skip larger parts of the, use the movie's Play button or drag to where you want 
the next caption to begin before clicking the Start button. A cue point will be set 
wherever you put the playhead. 

Background and Text 

Although the default text size and font is a good start, you may use whichever 
size, font, and color you wish for each caption. You can only choose the 
background color and text background height once, since the same background 
will be used throughout the caption track. You can reset the background color, 
background height as many times as you want to get it looking the way you want, 
however. Checking the Translucent background button will put the text in the 
lower portion of the movie (not below it) with the text being laid over a translucent 
box. Note that the Background color pulldown menu is deactivated while in this 
mode, and that the translucent background will not work in Preview mode, only in 
Embedded QuickTime exports. The Change All Captions button makes it much 
easier to experiment with how you want it to look. If you only want to change one 
or a few selected captions, use the Change Selected Caption(s) button instead of 
the Change All Captions button. SCC captions cannot have font properties 
applied to them. 

Note that the text properties of captions 
that have already been set will not change 
unless you click either the Change 
Selected Caption(s) button or the Change 
All Captions button! All new captions will 
automatically take on the settings you 
have set in the Text Properties. 

Typing a pipe "|" character will force 
a line break in your caption for 
better readability. This also works 

when editing in the caption list. Although the pipe character will show in 
MovieCaptioner, it will not be displayed in your final export. It is used only as a 
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marker for line breaks. Drag the vertical red line to the right to use as a visual 
guide as to where to put line breaks. See image below: 

 

In the event that the pipe symbol needs to be used as another character in a 
caption, you may select an alternative line break symbol under the 
MovieCaptioner Preferences window. You may choose either the ~ character or 
the ^ character as an alternative to the | character to force a line break. 

 

An easy way to add line breaks is to use the 
Add Line Breaks Automatically option 
under the Edit menu. You can set it to put a 
line break where it can between words at 
whatever character-count you want.  

It will automatically remove all previously set 
line breaks as well before adding new ones 
at a different character count. Choose which 
way it should count, left to right, or right to 

left before adding the line breaks. The Read right to left option should be used 
for Hebrew or Arabic text, as that is the direction that these languages are read. 

To remove all the forced carriage returns in your project, go to the Edit menu and 
select Delete All Line Breaks “|” in Caption List. 
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It is recommended that you do not change this, however, unless absolutely 
necessary as in the case of the “|” character being a necessary literal character 
used in the movie. Note you would need to change all previously set line breaks 
if you choose to change this as well, and that it could effect the export results of 
previously saved MovieCaptioner projects. A Find/Replace under the Edit menu 
could help you correct this, or you could more easily change it back to what it 
was before and just use the Remove All Line Breaks option under the Edit 
menu.  

Saving Captions 

After you set your text in the text area, just hit the Return key or click the Save 
Caption button to save the caption (Return key is much faster). The caption will 
appear in the caption list on the right and the movie will advance to the next few 
seconds. Repeat this process throughout your movie. You can save a blank text 
area if you want the previous caption to disappear after it is read. Otherwise, the 
caption will be displayed in your movie until a new one is triggered.  

 

It is generally acceptable to change captions in mid sentence, so don't worry 
about trying to have complete sentences for each caption. You can to some 
extent control the look of your captions by typing a "|" character that will force a 
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line break to even out your captions. The edit field where you type your new 
captions is not always an accurate representation of what you will see on your 
final captioned movies. Preview your movies in the QuickTime Player by clicking 
the Preview in QuickTime button to be sure of what your final captions will look 
like. Make sure you close the movie window in the QT Player to go back to 
editing in MovieCaptioner or you may end up with two sets of captions next time. 
The Preview button uses QuickTime SMIL format for display. 

Note that each time you set a caption, MovieCaptioner automatically saves your 
project. There is no need to save while you’re working. It will also save after each 
edit that you make to your captions. 

 
Editing Captions 

To edit any of your captions, just click into the caption you want to change in the 
caption list and type over it. Only edit in the caption list on the right instead of 
under the movie! Just remember that the text area under the movie should only 
be used for new captions and the list on the right should be used to edit captions. 
This will prevent an edited caption from possibly being added as a new caption at 
the end of the list.  
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Hit your Return key to confirm the change after you’re done editing in the caption 
list. The whole row in the caption list should turn blue (as in the picture above) 
when the change is entered. MovieCaptioner will save the change automatically. 
Typing the pipe "|" character will insert a line break in your caption (see 
Background and Text above). If you need to change this symbol, go to the 
MovieCaptioner Preferences window and choose between the alternate symbols, 
which are “^” and “~”. Do not change this unless you really need to, however, as 
it may affect previous projects. 

If you know how many characters wide you’d like to make your captions, you can 
move the red line to the right (by dragging the box on the bottom) to act as a 
visual guide so you can quickly go through and add forced line breaks.  

Use the Up/Down arrows to the left of the caption list to change the 
display size of the captions in the list. This will not affect the actual size of 
the exported caption text, however. It’s just for working in MovieCaptioner. 

Typing a paragraph tag "<p>" will cause the text to be broken up into 
paragraphs in HTML export and Transcripts (paragraph form). The paragraph 
tags will not be seen in other export formats. 

To edit a timecode, just click into it and change it. Please be sure to keep the 
proper formatting for the timecode! It should remain in this notation "hours : 
minutes : seconds . hundredths of a second" - note the decimal between seconds 
and hundredths of a second. Straying from this format may cause errors in your 
timing, or it may not allow the captions to be added. After you are done editing 
the timecode, hit your Return key to affect the change. MovieCaptioner will 
automatically reorder the rows if necessary. 

To remove a caption or captions, select its row in the caption list, and then click 
the Remove Caption button (or COMMAND+J). To insert a caption, click on the 
caption that you want your new caption to appear before, then click the Insert 
Caption button (or COMMAND+K).  MovieCaptioner will create a blank caption 
and give it a default timecode of about 1 second before the caption you selected. 
If no timecode is available it will default to 00:00:00.00.  Adding a blank caption 
between two timed captions will split the difference for the timecode between the 
previous and following captions. You may adjust the timecode as necessary by 
editing it directly in the caption list. Set your new caption as well by editing it in 
the list and hitting the Return key to set the caption. 

To Split a caption into two captions, click into the caption you want to split, then 
insert the cursor between the words where you want the split to occur (as if you 
were going to type something between those words). Then click the Split 
Caption button (or COMMAND+L). Everything to the right of the cursor will be 
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inserted into a new caption. MovieCaptioner will calculate the halfway point 
between the caption you are splitting and the following caption as the default for 
the caption that is split to a new row. Make sure you set the timecode properly for 
your new caption in the same format as the other timecodes. 

To move text from one caption to the next caption, click your cursor before the 
word you want moved, then click the Split To Next Caption button (or 
COMMAND+APOSTROPHE). All text from your caption after the cursor will be 
moved to the beginning of the next caption. This is especially helpful after 
importing text if you want to even out the captions or otherwise change the layout 
of the captions.  

To merge two consecutive captions click on the caption you want to be the first 
one, then click the Merge Captions button (or COMMAND+SEMICOLON). 
MovieCaptioner will take the second caption and add it to the first one that you 
selected, and will delete the second caption’s timecode as well.  

The captions can all be removed at once by selecting Delete All Captions in 
Caption List under the Edit menu. This is especially helpful if you import 
captions and decide you need to redo it for some reason. 

Spell Check 

As you type new captions, the live spell check will highlight misspelled words in a 
color other than that which you 
have chosen. The default white 
text will highlight in red.  

 

There is also a global spell 
check available that will 
check your whole project 
that can be started by 
going to the Spelling menu 
and choosing Check 
Spelling… 

This will launch the Spell 
Check window which will 
highlight each misspelled 
word in the Word Found 
field. If it is a word that you 
would like the spell check 
to remember, you can add 
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it to your personal word dictionary by clicking the + button next to this field. 

It will also give you up to 10 choices of different words to choose from that might 
be the word you need. Clicking on one of the choices will enable the Replace 
button and will replace the word when you click it.   

You may also skip or ignore a word by clicking either button. It will then bring up 
the next misspelled word or the Cancel button will change to Done, indicating 
that the spell check is complete. Please note that no changes will occur to 
any of the replaced words until the Done button is clicked! Then it will 
change them all at once. 

 

Importing Transcripts  

 

All imported files must be plain text ".txt" files using Unicode (UTF-8) Encoding, 
or you may get “gremlins”, stray characters that can goof up your project. 
MovieCaptioner will try to replace these unsupported characters with their 
supported counterparts or notify you that they are present and need to be taken 
care of manually. 

If you have transcripts already in text format, you can import them into 
MovieCaptioner to create text tracks for your movies. If you have text that is in 
paragraph form or text that is set line by line with returns, you can import the text 
into MovieCaptioner by either selecting Import Text In Paragraph Form or 
Import Text in Line Form from the Import menu. Make sure your text files are in 
plain text (.txt) format and not RTF, PDF, MS Word or any other format that 
contains hidden characters or they will be imported along with the text. Also be 
sure to save the text file using Unicode (UTF-8 Encoding). I recommend using 
BBEdit or their free version called Text Wrangler. Just copy/paste your text into a 
new document, and save it there. You can control how many characters are 
distributed per each caption by going to the Preferences under the 

MovieCaptioner menu.  

 Text that is imported in paragraph form will 
automatically be separated into captions by 
sentence. To do this, MovieCaptioner will 

look for periods, question marks, and exclamation points to separate them by. If 
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a sentence runs longer than 90 characters, MovieCaptioner tries to split it into 
two or more captions, looking for the space before the last word in the 90-
character segment to separate the captions. This number can be changed in the 
Preferences window. 

Text may be imported in paragraph form as show below: 

 
This is how the above text will import into MovieCaptioner: 

 

Text can also be imported in Line Form, such as these music lyrics: 
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This is how the lyrics will import into MovieCaptioner: 

 

Text imported in line form will simply be separated by line. Each line will be a 
separate caption in the caption list. Blank lines will be skipped. Text can also be 
imported including timecode at the beginning, followed by a tab, then the caption 
(the same way MovieCaptioner creates transcripts with timecode below): 

 

If properly formatted, the timecode will go into the appropriate field in the caption 
list. Note that whatever text and background properties that are set will be 
inherited for each caption. Other formats that can import timecode are STL, SUB, 
SRT, SCC, XML (timed text format), Adobe Encore, and SBV files from 
YouTube. Each of these has a separate option under the Import menu. 

The captions can be removed all at once by selecting Delete All Captions in 
Caption list under the Edit menu, or a few at a time by selecting captions and 
then choosing Remove Selected Caption(s) under the Edit menu. The Remove 
Caption button will do the same thing. 

Once the transcripts are imported, you may add the timecode simply by clicking 
the Set Timecode button that appears after importing a transcript as outlined 
below in Setting Timecode for Imported Transcripts. This button can also be 
made available by going to the View menu and selecting Show 'Set Timecode' 
button. You can use this to fine tune captions you set by typing as well. 

If special accented characters do not import properly, try going to the 
MovieCaptioner Preferences window and selecting a different Import Text 
Encoding.  
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You might want to try opening 
your text file in TextEdit to see 
what type of encoding it uses 

before selecting one from the pulldown menu. An easy way to do this is to open 
the file in TextEdit, then try to do a Save As. It will then display the default text 
encoding (such as UTF-16, for example) in the Plain Text Encoding pulldown 
menu. 

Setting Timecode for Imported Transcripts 
Once you've imported your transcripts, setting the timecode for each caption is 
easy. After you import transcripts either in paragraph form or in line form, a “Set 
Timecode” button will appear at the top of the caption list.  

 

The Set Timecode button, when clicked, will begin playing the movie and will set 
timecode every time you click it. If you do not hit the Return key before 10 
seconds passes, MovieCaptioner will automatically insert a blank caption so that 
the caption preceding it will expire. This is done so that if there is a long duration 
between spoken words in a movie, the captions won't need to be up the whole 
time. A blank caption will cause the previous one to disappear until the next 
caption appears. This option can essentially be disabled by putting a high 
number in for the expiration time. 

If there is no timecode imported with the text (as in the example above) the Set 
Timecode button will begin at the beginning of the movie, setting the timecode to 
"00:00:00.00".  The movie will continue to play and as each caption is spoken, hit 
your Return key or press Set Timecode so that MovieCaptioner will set a caption 
cue at that time point in the movie. So, it's as easy as listening to the movie and 
pressing your Return key whenever that caption is spoken. Once you've reached 
the end of your captions, it will stop automatically. Alternately, you can click the 
Stop button in the lower left under the Text Properties to stop setting timecode at 
any time. Note that if you make the MovieCaptioner interface wider, you'll be able 
to see the last words of each caption, which will help you anticipate the start of 
the next caption. You should attempt to hit the Return key at the beginning of 
each caption as it is spoken. That caption will always be highlighted in blue as 
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the one you are listening for. As soon as you hear the beginning of it, quickly hit 
the Return key. 

 
Click the Stop button to stop setting timecode. 

If you already have some timecode set for some captions, and stopped for some 
reason (by hitting the Stop button on the lower left), what you can do is to select 
the number for the last caption that has timecode, then click the Set Timecode 
button to resume setting timecode. What this will do is to tell MovieCaptioner to 
start at that timecode instead of at "00:00:00.00". Otherwise a blank timecode 
entry will trigger it to start at the beginning, and you wouldn't want that if you 
already have timecode set for 30 minutes of video, for example. So, just 
remember to select the last caption that has timecode before resuming with the 
Set Timecode button. See image below: 

 
To resume setting timecode after a stop, select the last caption that you have timecode for before 
pressing Set Timecode. 

This technique is also helpful if you want to fine-tune the timing that is set for a 
series of captions. For example, if you would like to reset the timing for captions 
26-30, first click on caption 25, then click the Set Timecode button to start 
retiming the captions. It will just overwrite the old caption timecodes. Alternately, 
you can fine tune all your captions by using the Set Timecode button and 
listening for each caption to be spoken, even if they were previously set using the 
Repeat Interval. The Set Timecode button is not limited to imported text, but can 
be used on any captions you have set to reset the timing if you wish. You can 
access the Set Timecode button at any time by selecting it under the View menu. 
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It can also be used to retime the whole project after splitting the captions up into 
a more readable form. 

Shift Start Times 

If you can see that your captions are out of synch 
by a few seconds, you can go to the Edit menu 
and select Shift Start Times to adjust the number 
of seconds you want the captions’ timecodes to be 
offset. You can either have the captions start 
sooner or later and you can either change all the 
captions or just the ones you have selected. 

You can use the Asset Start Timestamp calculate 
the time shift. This was originally used in DVD 
Studio Pro, but was adopted by MovieCaptioner to 
help calculate time shifts. Input timecode into the 
timecode form in this window, then hit the 
Calculate button. It will compute the seconds 
needed to offset the timecode and automatically 
select Later. Clicking the Shift Start Times button 

will affect the change. So if your captions that you imported started at 
00:01:30.00 and you want to start it at 00:00:00.00, then just copy the timecode 
from the first caption in your list and paste it into the Asset Start Timestamp, then 
click the Calculate button. It will calculate it to 90 seconds and selecting the 
Sooner radio button would move the first caption to 00:00:00.00 and the rest of 
the captions would move 90 seconds sooner as well. 

Importing SCC Format Files 
MovieCaptioner can import Sonic Scenarist (SCC) files. Choose this option from 
the Import menu. It will import the captions and timing from the SCC file. Note 
that the timecode you get from SCC files will be different from what is in the SCC 
file itself. This is because SCC format requires a buffer time depending on the 
length of each caption. MovieCaptioner will calculate the standard buffer time 
(one frame per 4-digit binary number of an SCC caption) and remove it, making 
the timecode appear slightly later than what is listed in the SCC file. This is 
normal and will make for more accurate synchronization for other caption formats 
that do not need the buffer time. Exporting to SCC will add this standard buffer 
time back in. 

If the SCC file imports with 1 hour-based timecode (first caption starts at 1 hour 
instead of 00), you will need to go to the Edit menu and choose Timecode to 0 
Start Time. Otherwise, your timecode may not work accurately in other formats. 
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Check to make sure the timecode at the end of the movie is accurate if the movie 
is longer than one hour. Final Cut Pro 7 users should use the 00 HR start time for 
SCC captions. 

Importing QuickTime Text Files 
MovieCaptioner can import the timecode and captions from a QuickTime text file. 
It will not currently import font styling, so set your text properties the way you 
want them set before importing the QuickTime text file. 

Importing CART Files 
CART (Communication Access Realtime Translation) files must be in plain text 
(.txt) format to import properly. 
Previewing Your Work and Creating the Final Text Track 
You can preview your captions by clicking the Preview button. This will launch 
either launch the built-in MovieCaptioner Player. The built-in MovieCaptioner 
Player will allow you to save the movie by using the Save As button in its lower 
left corner without the need to own QuickTime Pro. QuickTime Pro is still 
recommended, however, in case you need to make adjustments to the caption 
track or in case you need to export as a new movie. 

 

You may also use the QuickTime 7 Player to preview your captioned movies if 
you go to the MovieCaptioner Preferences window and select QuickTime Player 
from the Preview player selector. 
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You need to have QuickTime 7 installed in order to be able to use the QuickTime 
Player for Previews and embedding in QuickTime. Just play the movie in the 
preview player to view your work so far. If you're all done with your captions and 
it looks okay in QuickTime Player, just close the movie in QuickTime Player then 
go to the Export menu in MovieCaptioner and select the desired output format. 

 

If you still need to do some editing, close the preview player and continue on 
with your editing. Keep in mind that the edit field where you type in your captions 
is not always a good representation of how your final captions will look when they 
are added in QuickTime. It can dependent upon your font, text style, and font 
size. So, you may want to Preview your captions from time to time until you get a 
good feel for how much text you can add for any one caption with the particular 
font and size you are using. If you are using the SCC format as your final export 
choice, the Preview is not the best option. Instead, export as Sonic Scenarist 
(SCC Embed in QT) to see what they will look like as this format is very different 
from most of the other formats. You will need QuickTime Pro and the 
ClosedCaptionImporter plugin for QuickTime to embed SCC captions into your 
movie. 
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Removing Captions from a Previously Captioned Movie 
Should you decide to make any changes to your captions after saving your movie 
that has an embedded caption track, you must first delete the caption track from 
you video. Just select Remove Text Track From Movie from the Edit menu. You 
will need to have QuickTime Pro in order to remove a caption track from a movie. 
This action is not undoable. It also may not work on text tracks that were not 
created by MovieCaptioner. It will depend on what the movie's text track was 
named when it was created (MovieCaptioner will look for a track called "Text 
Track" to delete). Also note that if you select one of the Embedded QT exports, 
and you end up seeing two sets of captions (top and bottom), you probably 
already have a caption track in the movie and it will need to be removed before 
adding a new caption track. You may have just forgotten to close the QT movie 
before going back to MovieCaptioner. If the movie was saved, with a text track 
embedded, however, you’ll need to remove it. Once you click the Remove Text 
Track From Movie in the Edit menu, the QuickTime Player will be launched, the 
caption track removed, and the movie automatically reloaded into your project 
interface in MovieCaptioner. To remove a text track manually, open your movie in 
QuickTime Pro, go to the Movie Properties window, select the track you wish to 
remove, then click the Delete button. Then save your movie. 
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Changing the Location of a Text Track  
You may also change the location of the text track to either below the movie or to 
be covering the bottom portion of a movie (whatever you have chosen as the text 
background height). Click on the Change Text Track Location under the Edit 
menu to select one of these two options.  
Note that the SCC export and the Translucent background option will both place 
your captions automatically over the bottom portion of the movie, so you won’t 
need to select where they will go.  

An even better option would be to click the Translucent Background option in the 
Text Properties area. This will put the captions over the bottom portion of the 
movie, but they will be over a translucent background so you can still see the 
movie through it, but the text will be easy to read. Checking the Translucent 
Background option overrides any text track location settings that you may set. 

Undo, Redo, and Revert To Previous Version 

The Undo and Redo under the Edit menu works on a caption-by-caption basis. 
Once a caption is set it is automatically saved. You may Undo and Redo to the 
previously saved caption as long as you have your project window open. Once 
you make a change, however, you will no longer be able to Redo. A Temp folder 
will be created in your MovieCaptioner folder in your Application Support folder 
where all the scratch files will be saved. These will be deleted when you close 
your project. Before they are deleted, however, they will be copied to a Backup 
folder one directory up from the Temp folder. These can be accessed from the 
File menu should you need to revert to an earlier version for some reason. 

When you open a project you’ve worked on before, the Revert to Previous 
Version option under the File menu becomes enabled. If you choose this, it will 
revert to the state it was in when you first opened it during that session. So if you 
make a bunch of changes, then decide that you don’t want to keep them, you can 
go back to the way it was when you first opened the project. This option is not 
available for new projects as that would basically blank out all the captions. The 
Revert option is handy if you want to reformat your captions for a specific export, 
but don’t want to keep it that way in the long run. This might have to do with the 
way captions are broken up, perhaps, for some export formats. 
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Backups Folder 

 

A Backups folder is now written to the ~user/Library/Application 
Support/MovieCaptioner folder. This folder is easily accessible from 
MovieCaptioner’s File menu and can be a life saver if for some reason your 
project file gets goofed up.  

 

Open the folder with the date that you created the project and you will find up to 
ten project versions. Selecting the version with the highest number appended to 
the name will usually give you the latest version. It might actually be the date 
when you first closed the project as well, as this is when the files are copied to 
the Backups folder. When you close a project, any files in the Temp folder will be 
copied over to the Backups folder, so if MovieCaptioner were to crash and when 
you reopened it, you didn’t see your last changes, you might be able to open one 
of these files to get one of the most recent versions. The files will be copied to a 
folder under the date when they were copied (not necessarily created). When 
you open MovieCaptioner, if it sees that there are files in the Temp folder, it will 
automatically copy these files over to the Backups folder. It will assume that for 
some reason MovieCaptioner crashed and could not backup these files the last 
time it was open. This is (hopefully) a fail-safe way of not losing hours worth of 
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work. Using Time Machine or some other automatic backup system is also a 
good work practice for anyone and is highly recommended. 

It might be a good idea to delete old project files in the Backup Folder that you 
don’t need anymore. They can really pile up if you do a a lot of captioning. 

 

Export Formats 
Creating Embedded QuickTime Text Captions 
When you are all done with setting your captions (or you just want to see what 
they will look like), select the Embedded QuickTime option under the Export 
menu. MovieCaptioner will create an XML file (in the same directory as your 
movie) with all your captions in it, copy them, and then launch the Preview Player 
or QuickTime Player (Pro version required) if selected to embed the captions. If 
QuickTime Player fails to launch, it usually means that you have some timecode 
problem in your project (caption times may not be sequential) or that it could not 
write the text file in the same directory as your movie. This could be because the 
movie is on a DVD or CD or some other volume that you don’t have write 
permissions to. If that is the case, move your movie to your main hard drive (like 
the Desktop) and relink your movie to your project.  

Creating a QuickTime SMIL Captioned Movie 
When you are all done with setting your captions, click the QuickTime SMIL 
button. MovieCaptioner will create several files, one with a ".xml" extension, and 
one with a "qt.smi" extension. If you have selected the Translucent Background 
option a file called “bkgd.txt” will also be created. It will then launch the file with 
the ".qt.smi" extension in the QuickTime Player. If uploading this to a server, 
make sure you keep all these files in the same directory or it will not work 
properly. So, the ".mov" file, the ".xml" file, the optional “bkgd.txt” file, and the 
".qt.smi" file should all be together. Make any links you have to the ".qt.smi" file. 
This file will in turn reference both the ".mov" file and the ".txt" file to display the 
captions. If you see a blank box with the name of the language ("English" for 
instance) below the movie, it usually means there is some timecode that is not in 
proper order or it could mean that it could not write the text files to the same 
directory as the movie. Adjust as necessary then try again. 

Creating a Flash XML File 
Flash has the ability to link to an XML file for the purpose of displaying captions. 
MovieCaptioner will create this file for you when you click the Flash XML button. 
You can either use a QuickTime movie to create your captions or if you go to 
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http://perian.org, they have a free plug-in for the QuickTime Player that will allow 
you to load an FLV movie into MovieCaptioner (and play FLV's in QT Player as 
well). Note that you will not be able to create embedded captions or SMIL files 
using an FLV, but it works well for FlashXML files and transcripts. 
The XML file will be saved to your hard drive (in the same folder as your movie) 
calling it "captions.xml". To use this file, launch Flash (CS3 or newer) and create 
a new Actionscript 3.0 Flash file into which you will import your movie. You don't 
need to add any cue points. The XML will do that for you. Select a skin that 
contains the words "Play" and "Caption". In this example I'm using 
"SkinUnderPlayCaption.swf". After importing your movie, go to the Components 
window (under the Window menu) and select the FLVPlaybackCaptioning 
component and drag a copy of it to the stage (don't worry, it will be invisible). See 
image below. 

 

Once you've done that, click on this component on the stage, and go to the 
Components Inspector window (under the Windows menu again). While the 
component is still selected, click on the Parameters tab in the Component 
Inspector window and change the Source parameter to the XML file that 
MovieCaptioner created. Test your Flash movie by publishing it. You should 
always keep the XML file with this Flash movie.  
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Creating YouTube Captions 
Selecting this option will create a 
.SRT formatted file which you 
can upload to YouTube. Once 
you export this file, go to your 
movie’s page on YouTube and 
select the downward-facing 
arrow next to Annotations at the 
top of the page.  

 

Next, click the Upload caption file or transcript button. 

 

Then just and locate the .SRT file on your hard drive  and use the Choose button 
to upload your caption file. Your captions should display the next time you view 
your movie. 

 



	   26	  

Note: If you do not like the way YouTube displays your captions (sometimes they 
may have a long line then one word on the second line) you can adjust it by 
adding carriage returns to your SRT or SUB file. Just watch you video as the 
captions appear and stop it when you see one you do not like. Use carriage 
returns to break up the text to a more orderly display and save your SRT file. The 
red guide on the MovieCaptioner interface is helpful for doing this. Once you’re 
done editing, just delete the caption file that you uploaded to YouTube before 
and upload the edited one in its place. 
Creating JW Player Timed Text (TT) Files 
Select this option if you want to create captioned text files to be used with the JW 
Player. More information about this player and how to make your videos 
accessible with it can be found at 
http://www.longtailvideo.com/addons/plugins/84/Captions?q=. 
Creating Common Look and Feel Player Timed Text (TT) Files 
Select this option if you want to create captioned text files to be used with the 
Common Look and Feel (CLF) Player. More information about this player and 
how to make your videos accessible with it can be found at:   
http://commonlookandfeel.ca/clf/about/ 

Creating Adobe Encore Caption Files 
Select this option if you want to create captioned text files to import into Adobe 
Encore's DVD-making software. You can also use the SCC format for creating 
closed captions with Encore, but make sure you start the first caption no sooner 
than 00:00:02.00 or the captions may not burn to DVD properly. This is a bug in 
Adobe Encore. 
Creating Sonic Scenarist (SCC) Caption Files (for iPods, 
iPhones, and Broadcasting) 
There are 3 options when it comes to SCC captions. The first will embed the 
captions into your QT movie. The second is for using with Final Cut Pro, DVD 
Studio Pro, and other software that uses this format. The third option is used 
specifically for Adobe Premiere CS5.5, which can now display captions in its 
Preview window. 

Note: You must have the ClosedCaptionImporter.component plug-in for 
QuickTime (available from Apple) to get MovieCaptioner to embed SCC closed 
captions into a QuickTime movie. At the current time, it is available here:  
http://developer.apple.com/samplecode/ClosedCaptionImporter/ or from the 

http://www.telestream.net/flip4mac-wmv/overview.htm
http://commonlookandfeel.ca/about/
http://developer.apple.com/samplecode/ClosedCatpionImporter/
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SynchriMedia site here:  
http://www.synchrimedia.com/ClosedCaptionImporter.zip 
Click the Download Sample Code link on the Apple site, then remove the 
ClosedCaptionImporter.component plug-in from the downloaded folder and put it 
in your hard drive's Library/QuickTime folder. Make sure you quit out of the 
QuickTime Player first! QuickTime will not recognize the new plug-in until it re-
launches. 

There seems to be a bug in QuickTime that does not keep SCC captions that 
MovieCaptioner embeds in the movie. If after embedding SCC captions in your 
movie you quit QuickTime Player and open it again, it will not be able to display 
the captions, even though the closed caption track is still present. So although 
you can use the Sonic Scenarist (SCC Embed in QT) as a method of previewing 
SCC captions, if you want to make them permanent you will need to use Subler, 
a free app from Google. You can download it here: 
http://code.google.com/p/subler/ 

To use Subler, open a new window from the File menu, drag 
your movie to the interface, then drag your SCC file to the 
interface. From the File menu choose Save As.  

 

Make sure that Video-MPEG4 is selected from the File Format menu… 

http://www.synchrimedia.com/ClosedCaptionImporter.zip
http://code.google.com/p/subler/
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When you play the resulting movie in QuickTime Player, go to the View menu 
and select Show Closed Captioning. 

You may control which SCC row each caption starts on by selecting a caption on 
the right, then selecting the row number (1-15) in the SCC Row pulldown menu. 
Then click the Change button to set the row. When a caption is clicked on in the 
caption list on the right, its SCC row will be displayed in the SCC Row pulldown 
menu. You may also set the SCC Row pulldown, then go to the Edit menu and 
choose Change All SCC Rows To Current Selection to change all captions to 
start on that row. 

If you do not click the Change button after 
changing the pulldown menu, the change will not 
take effect. 

Selecting Sonic Scenarist (SCC file only) will only create the SCC text file and 
will not import it into your QT movie. Please use the SCC embed in QT option to 
check your work, however. Exporting the file only is to be used for importing the 
file into Subler, Adobe Encore, Final Cut Pro, or DVD Studio Pro.  
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Since Adobe Premiere CS5.5 seems to have its own flavor of SCC captions, a 
special export had to be created just for that purpose called Sonic Scenarist 
(SCC File, Premiere Compatible). 

You can also use the SCC format for creating closed captions with Adobe 
Encore, but make sure you start the first caption no sooner than 00:00:02.00 or 
the captions may not burn to DVD properly. This is a bug in Adobe Encore. 
The SCC format buffers the captions before displaying them, so MovieCaptioner 
will calculate the required buffer time and move the timecode up accordingly to 
allow the captions to show up at the proper time. Otherwise they will come up a 
second or two too late for the video. So, bear this in mind if you see that the 
timecode in the resulting SCC file is different from what you see in 
MovieCaptioner. This is normal and will result in more accurate synchronization. 

At this time, MovieCaptioner can only put the SCC centered, left justified. Note 
also that SCC captions can have no more than 32 characters (including spaces) 
per line of captions, and only 4 rows can be visible at a time. MovieCaptioner will 
run two passes on export to check each line for length and add the pipe "|" 
symbol where necessary to break up lines. You may want to remove any pipe 
symbols that you have previously and let MovieCaptioner do it for you. It tends to 
work better that way. You can do this easily by going to the Edit menu and 
selecting Remove All Line Breaks “|”. Try this if you see that some of your 
captions are getting truncated. Then export as SCC again. If this will affect other 
exports, then you may want to create an SCC only version of your project or use 
the Revert to Previous Version option. If it suddenly gives you an error saying 
there are too many lines in a particular caption, try removing all the line breaks 
and exporting again. That usually clears up that problem. Or you can try quitting 
out of MovieCaptioner and relaunching it if your captions come up blank. 
Tip: If you are importing text, it would be best to set your text import settings to 
no more than 60 characters in the MovieCaptioner Preferences window if you 
know you will be exporting as SCC. On export, MovieCaptioner will check each 
caption and put line breaks into any caption that is longer than 32 characters 
automatically. If there are more than 4 lines of text, MovieCaptioner will stop the 
export and notify you as to which caption is too long. You must shorten that 
caption by either removing  characters or splitting the caption up into two 
captions. You should also try to keep SCC captions at least a couple seconds 
apart to prevent overlap errors which can be common to the SCC format. 

Once you have the .SCC file, you can import this into Final Cut Pro 7, and create 
line 21 captions. When you “Print to Tape”, it will ask you if you want to add 
closed captions and will allow you to import the file and create the line 21 closed 
captions for you after the file is imported. You should use the 00 HR Start Time 
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(under the Edit menu) if going to Final Cut Pro 7 as Final Cut handles the time 
relative to the start of the clip. If adding bars and tone in Final Cut, you should 
use the Shift All Start Times by the number of seconds of your bars and tone. It’s 
best, though, to have the bars and tone on a low res version of the movie that 
you use only in MovieCaptioner just to get the timing and captions right.  

Some software may require you to have the timecode starting at 01 hours. You 
can do this by going to the Edit menu and selecting Timecode to 01 HR Start 
Time. Use this only after making sure your caption timing is all set, as in the case 
with SCC captions, where you will probably need to shift the start times of the 
captions using the Shift All Start Times option under the Edit menu. Note also 
that using the 01 HR start time may not work with embedded QuickTime 
captions.  

Creating Spruce STL Caption Files 
Select this option if you want to create captioned text files to import into Apple's 
DVD Studio Pro software. Note that STL files may also be imported into 
MovieCaptioner. This might be done possibly to create a caption track in another 
language, for example.  

Creating SRT and SUB Files for YouTube or DVD Software 
Select SRT or SUB if you would like to create files compatible with YouTube, or 
DVD software. See instructions above for creating YouTube captions. You can 
also use SRT caption files and add them to your QuickTime movie using Subler, 
a free app from Google. You can download it here: 
http://code.google.com/p/subler/ 

To use it, just open a new Subler project window, drag your movie to the window, 
then drag your SRT file to the window. Then Save As and it will create a “.m4v” 
movie that will display captions in the QuickTime Player. 

Creating SAMI Captions 
SAMI files are caption text files that are used with Windows Media Player. You 
can create captions for Windows Media movies (WMV) if you have the Flip4Mac 
plug-in that allows the QuickTime Player to play Windows Media files. This will 
allow you to actually load a Windows Media movie into the MovieCaptioner 
project and set the captions for it just like QuickTime. To download the plug-in, 
go to: http://www.telestream.net/flip4mac-wmv/overview.htm. 
Upon choosing the SAMI File export, MovieCaptioner will create 2 files: One will 
have a ".smi" extension and the other will be a ".asx" file. These two files must 
always be located in the same folder as your Windows Media movie or they will 

http://code.google.com/p/subler/
http://www.telestream.net/flip4mac-wmv/overview.htm
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not play. The ".asx" file is the file you will load into the Windows Media Player. It 
will join the caption file (.smi) with the movie file to synchronize the text with the 
movie. There is still another step, however, if you plan to use them online. 

If you will be uploading the files to your server for people to view online, you will 
need to make a change to the “.asx” file. For some reason, Windows Media may 
not play the files properly unless you use an absolute URL to the two files. So, for 
example if my SAMI files are uploaded to the following folder on my server:  
http://www.myserver.com/movies/, then I know to change the line referring to 
these files in the asx file to:                  

<ref href="http://www.myserver.com/movies/mymovie.wmv?sami= 
http://www.myserver.com/movies/mymovie.smi" /> (all on one line) 

Prior to my changing it, the line would have looked like this:                                

 <ref href=”mymovie.wmv?sami=mymovie.smi” /> 

By default, the Windows Media Player does not display captions. You will need to 
select "Show Captions and Subtitles" from the Play menu in Windows Media 
Player on Windows to see your captions if they do not appear. There is also a 
similar setting in the Preferences under the Security tab you may also need to set 
to play captions and subtitles if available.  Also, captions may not look right when 
viewed with Windows Media Player on a Mac. The Mac version of Windows 
Media is not very good. Try your SAMI files on a Windows machine before 
concluding that there are problems. You can get away with not using the “.asx” 
file as long as the “.smi” file has the same name as your movie. Windows Media 
will automatically associate it with the movie in that case. 

Creating WMP Text Files 
WMP text files are a little-used method of embedding captions into a Windows 
Media Player video. MovieCaptioner will make the text file for you. From there 
you will need to use something like Windows Media Encoder 9 to embed the 
WMP.txt file into the movie. This is handy because the movie and captions will be 
self-contained in one file instead of up to 3 files as in SAMI captions. The 
Windows 9 Encoder is free, but only available for Windows machines. You can 
download it here:                                                              
http://www.microsoft.com/en-us/download/details.aspx?id=17792 

To use it, open the Windows Media Components folder and then open the 
Encoder folder. Then launch the “wmeditor.exe” file. 

http://www.microsoft.com/en-us/download/details.aspx?id=17792
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When the Windows Media File Editor opens, go to File > Open and open your 
movie, then go under the File menu and choose Import header file… 

 

Choose the WMP Text file you exported from MovieCaptioner. Then choose 
Save As and Index, give it a name and save it. The WMP Text file should display 
captions if they are turned on in Windows Media Player. 
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HTML5/Timesheets 
This is an adaptation of the SMIL/Timesheets solution created by Fabien 
Cazenave. More information can be found at this website: 
http://wam.inrialpes.fr/timesheets/annotations/video.html. Choosing this option 
will create and launch an HTML5 web page with the video embed code written 
for all three HTML5 supported video formats: MP4, OGG, and WEBM. 
MovieCaptioner will not export these different video formats, so you will need to 
create all 3 video formats of your movie to insure that your video will be visible on 
major browsers that support html5 markup. Please refer to the html5 web page 
created by MovieCaptioner to make sure you name the movie properly, or you 
can just change the HTML5 markup accordingly. What you choose for the 
background color will become the background color of the Web page. 

http://wam.inrialpes.fr/timesheets/annotations/video.html
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                              HTML5/Timesheet Captions as seen in the browser  

MovieCaptioner will write the HTML5 Web page called “timesheet.html” and also 
a file called “timesheets.js”. Both of these files will be written to the same folder 
as your movie on your hard drive. Be sure to include these files with your movie 
when uploading to your Web site. 

Creating WebVTT Caption Files 
Select HTML5 WebVTT from MovieCaptioner’s export window to create a file 
that can be used for HTML5 captions. At this time font attributes and alignment 
are not supported and must be added manually after exporting.   
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Upon selecting the WebVTT export, you will be prompted to add a title for the 
Web page and a short description of the movie (both optional). Then just click the 
Create Web Page with WebVTT Captions button and MovieCaptioner will write 
the HTML5 code and launch the Web page with the WebVTT captions linked to 
it. You should make sure to include both an MP4 and an OGG version of your 
movie so most accepted browsers will display it. 

    

Make sure to include the html file, both versions of your movie, and the WebVTT 
caption file, which should be named the same as your movie with a “.vtt” 
extension when you upload to your Web server. 

 

Creating Text Transcripts 
By using one of the Transcript export options, MovieCaptioner will save all your 
captions into one succinct text file, in either paragraph form where all text is 
compiled into a paragraph, or in timecode form where each caption's timecode is 
listed next to the caption and a space is put between lines. This type of transcript 
makes a good backup of your project as well, as it can be imported with timecode 
intact.  

If you have accented characters in your captions that do not appear properly 
once exported as transcripts, try changing your MovieCaptioner export 
preferences to UTF-16. 
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Typing a paragraph tag "<p>" will cause the text to be broken up into paragraphs 
in HTML export and Transcripts (paragraph form). The paragraph tags will not be 
seen in other export formats. 
And, if you are going to identify speakers, MovieCaptioner will automatically put 
an extra space every time it sees a "[" character to make the transcripts more 
readable like a movie script. For example if you have two people talking in your 
movie or podcast, and you use the convention: 
[ person's name ] What they said. 
Your transcript will be written with a space between each speaker's lines: 
[ Bill McCoy ]  Hello, welcome to this week's podcast. 

[ Frank Adams ]  Yes, Bill, we have a great show lined up for you today. 

Another advantage of creating a transcript of your captions is that you can then 
easily take it into Microsoft Word or a similar text editing s/w and do a spell check 
and set any formatting that you like to the document. 

Creating HTML Transcripts 
By clicking the HTML option, MovieCaptioner will save all your captions into a 
web page, separating it by paragraphs if you use paragraph tags "<p>" in the 
captions. Note that other export options will ignore the <p> tags, so you don't 
have to worry about them showing up in your embedded QuickTime captions, for 
example. Again, if you have accented characters that do not appear properly, 
change your MovieCaptioner export preferences to UTF-16. 

 
Setting Your Preferences  
If you want MovieCaptioner to open new projects with a certain font, size, style, 
and color as the default, go to the MovieCaptioner menu and choose 
"Preferences...". There you can set your text preferences as well as your 
background color, background height in pixels, translucency, Repeat Interval, 
and an alternate line break symbol. Note that changing the preferences will not 
affect your current project, but rather it will set the default for all new projects. 
The checkbox for Translucent background will take effect immediately, however, 
once you click the Save Preferences button. You may also set the maximum 
number of characters that each caption will have when importing text into 
MovieCaptioner. 
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Setting the language is important for both SMIL and DFXP/XML captions. This 
would be referencing the target computer's language setting (not the keyboard 
setting). If you have a text file that you know is saved in another format, you can 
set Import Text Encoding to that format before importing to prevent importing 
garbage characters. The Export FPS pulldown menu allows you to select either 
30 frames per second (non-drop frame), 25 frames per second (non-drop frame), 
29.97 frames per second (drop frame), and 23.98 frames per second (drop 
frame). This setting will be used for some export formats where the frame rate is 
taken into account such as SCC captions. The setting will be displayed between 
the movie player and the caption list in the MovieCaptioner interface. 

 

Clicking this number is a quick way to get to the Preferences window to change it 
again. 
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Troubleshooting 
• The Spellcheck Dictionary MUST remain in the same folder as the MovieCaptioner 
application file or it will ask you where the dictionary is each time you open 
MovieCaptioner. It needs to stay in the same folder to work properly. 

• MovieCaptioner will always display timecode in this format – HH:MM:SS.ss            
note the decimal between seconds and hundredths of a second. Do not try to put 
semicolons into the timecode box. It will output drop frame timecode when you export if 
you have it set correctly in the Preferences window.  

• Movies that use AVC Coding may not save properly after adding captions. . It will 
often give an error “end of file reached” and the save will fail. This is a bug with that 
codec and has nothing to do with MovieCaptioner. Best to re-export the movie from 
MPEG Streamclip (free from http://www.squared5.com) if you run into this problem, 
then reload it into your project by going to the File menu and selecting Load Movie. 
Movies using AVC Coding may even cause MovieCaptioner to crash. 

• MovieCaptioner works best if both the project file and the movie you are using are 
both stored on your computer’s main hard drive instead of an external hard drive or 
mounted volume. This will ensure that it can find the movie’s directory easily to write the 
files it needs for some exports. 

• MovieCaptioner should be kept in its own folder and that folder should be installed in 
the main hard drive’s Applications folder. MovieCaptioner will check to see if it is 
installed properly when it is first opened. This is especially important for the spell check 
to work properly. 

• You must install QuickTime 7, which is available on the Snow Leopard or Lion install 
disk (or from the Apple Web site) to get all the features of QuickTime Pro that are 
necessary for MovieCaptioner to work properly. Finished movies will of course work in 
the QuickTime X Player, but it just will not work for the caption creation process. 

• It is always best to start captions (even if they are blank) at 00:00:00.00. The 
only exception to this would be if you are exporting SCC files for use with Adobe 
Encore. In that case change the first caption to start at 00:00:02.00. 

• Having the wrong Import Encoding setting in the Preferences window could cause 
MovieCaptioner to crash on import of a caption file. In most cases, using UTF-8 is the 
best choice. Make sure you save any files you import as plain text (no docs or rtfs) and 
that they are saved using the UTF-8 Encoding option. For example, if you have Chinese 
text in a Word document, save it as a plain text document and use the UTF-8 Encoding 
option. This should make it import into MovieCaptioner correctly. 

http://www.squared5.com
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• It is also best to not use large HD movies with a frame rate of higher than 30 frames 
per second as they can bog down MovieCaptioner and cause it to stutter at some point. 
You can use a low resolution movie (like 320x240) just to create the captions, then 
swap out a higher resolution version using File > Load Movie if you need to embed the 
captions into the video. If you’re just exporting a caption file, the small version of the 
movie will work better for setting captions. 

• Make sure you have the ClosedCaptionImporter.component plug-in for exporting SCC 
closed caption files. It needs to be put in your Library/QuickTime folder. If you are using 
OS X 10.7 (Lion), Apple has hidden the Library folder. You can find it by going to the 
Finder’s Go menu, selecting Go To Folder, and typing in “~/Library/QuickTime”. Using 
this plugin is really only a method to preview your captions in SCC format. QuickTime 
will not be able to display the captions on another computer or even after you quit out of 
QT Player and relaunch it again. You must use either Subler or Compressor to embed 
your final SCC captions. 

• MovieCaptioner will Undo/Redo on a caption-by-caption basis. You may also 
revert to the version that you originally opened during that session. A 
MovieCaptioner/Temp folder will be created in your ~user/Library/Applications 
Support folder for this purpose. All temp files will be deleted after you close your 
project. They will, however, be copied to the Backup folder under today’s date. 
These files are easily accessible from the MovieCaptioner File menu. It might be 
a good idea to clear this folder of unneeded old project versions at some point. 

• SMIL-captioned movies may not display the text if the viewer's computer is set 
to a different language than what the SMIL captions are set to. So, if you are 
creating SMIL captions, set the language to what the target audience's computer 
language will be set to. This can be done in the Preferences window. You may 
need to create and link to different SMIL files to accommodate your audience's 
languages. 

• The option to change the timecode start time to 01: hours should not be used 
with embedded QuickTime. It should also only be used after setting all captions. 
If you are exporting SCC for Final Cut Pro, then leave the start time at 00: hours 
even if your movie starts at 01: hours.  

• The Undo option will not become disabled once the last undo has been used. It 
will instead change to “Cannot Undo”. 

• Using BBedit or the free version, Text Wrangler, is recommended for working with the 
text files you create and/or import with MovieCaptioner. Text Edit and MS Word are not 
recommended as they tend to introduce garbage formatting characters that may mess 
up your projects. It is usually best to save text files with UTF-8 encoding and Unix line 
breaks for best results when importing files into MovieCaptioner. 
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• If in the Preview you see too much space on the right side of the movie, you 
may need to reset your movie’s text track width. This should be the same width 
as the movie in pixels. You can reset this under the Edit menu by choosing 
Adjust Text Track Size. 

• If you imported text and it does not appear in the caption list as it should, you 
may have selected the wrong format (paragraph form or line by line form). Note 
that these imported text files must be text-only (not RTF or MS Word and no 
photos or other types of formatting). 

• Make sure your movies have a video track and a sound track and not a single 
muxed track that you get with MPEG-1 and MPEG-2 videos. A muxed track will 
cause issues when you go to embed captions. You can tell by opening the movie 
in QT Pro and selecting the Show Movie Properties window. If you have a single 
muxed track, you will need some s/w such as MPEG StreamClip to break it up 
into separate audio and video tracks. The free application “MPEG Streamclip” 
may help  you with this. 

• If you export as SCC format and instead of seeing captions you see a black 
screen with "Sonic Scenarist V1.0", you probably have an issue with timecode in 
your project. Make sure all timecodes are in sequence and preferably at least 
one second apart to give the player enough time to buffer the next captions. 
Otherwise they could be skipped. Sometimes going to the Edit menu and 
selecting Delete All Line Breaks “|” In Caption List and then re-exporting the 
SCC file will fix it. MovieCaptioner does a very good job of breaking up the 
captions by 32 character lines between words, so it’s best to let it do its line 
breaks, unless there are obvious places where the line should break. You can 
find my SCC troubleshooting blog post here: 
http://synchrimedia.blogspot.com/2011/06/troubleshooting-scc-line-21-caption.html 

Your Input is Very Important! 
Please help me to improve MovieCaptioner. Let me know what you like and what 
you dislike about MovieCaptioner. Most all of the changes in this version of 
MovieCaptioner were a direct result of user comments. If you have any ideas or 
things you'd like MovieCaptioner to be able to do, please contact me at 
support@synchrimedia.com. But, please be patient, though, as Synchrimedia is 
still a one-man show. 
Thank you for using MovieCaptioner!  
- Patrick Besong 
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