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   How to Use MovieCaptioner 
Please take a few minutes to familiarize yourself with these instructions 
before starting to work with MovieCaptioner. In addition to these 
instructions, there are helpful videos on the website at 

http://www.synchrimedia.com/tutorials.html that will help you with creating captions, 
editing your captions, and outputting your captions and transcripts. The link is also 
available under the Help menu. 
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Mac and Windows Version Differences 
Although this is the first version of MovieCaptioner for Windows, it has many of the 
same features as MovieCaptioner for Mac. There are some basic differences, however.  
• You must use either MPEG-4 and QuickTime movies on this Windows version.  You 
can download a free video converter called Prism from 
http://www.nchsoftware.com/prism/index.html that will allow you to convert your WMV movie 
to either a “.mov” or “.mp4” file. 

• Flash (FLV) files cannot be loaded as there is not a Perian plugin for Windows like 
there is for the Mac. 

• SCC captions cannot be embedded into a movie on Windows, since Apple has not 
created a Windows version of the ClosedCaptionImporter plugin for QuickTime. Note 
that as of Adobe Premiere CS5.5, SCC captions can be imported and viewed over your 
movie. 

• At this time, QuickTime Pro 7 is still required for the Mac, but not required for 
Windows.  

 

Requirements (somewhat dependent upon the type of files you create) 

•  Windows XP, Windows 7, or newer 

• QuickTime Player 7 or newer  

• QuickTime Pro still recommended, but not necessary 

 

Known Issues and Best Practices 

• You must use either MPEG-4 and QuickTime movies. If you need to create SAMI 
captions or WMP Text  files, resave your WMV movie as a QT movie using the same 
name. As long as the video is identical in duration it will make no difference. You will 
only use the QT movie to create the captions and timing. Your final product will use 
your WMV movie. You can download a free video converter called Prism from 
http://www.nchsoftware.com/prism/index.html that will allow you to convert your WMV movie 
to either a “.mov” or “.mp4” file. 

• MovieCaptioner works best if both the project file and the movie you are using are 
both stored on your computer’s main hard drive instead of an external hard drive or 
mounted volume. This will ensure that it can find the movie’s directory easily to write the 
files it needs for some exports. 

http://www.nchsoftware.com/prism/index.html
http://www.nchsoftware.com/prism/index.html
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• MovieCaptioner should be kept in its own folder and that folder should be installed in 
the main hard drive’s My Applications or Program Files folder 

• Having the wrong Import Encoding setting in the Preferences window could cause 
MovieCaptioner to crash on import of a caption file. In most cases, using UTF-8 is the 
best choice. 

• It is also best to not use movies with a frame rate of higher than 30 frames per second 
as they can bog down MovieCaptioner and cause it to stutter at some point. If 
necessary, you may substitute the higher frame rate version of the movie after you are 
done creating captions by going to the File menu and selecting Load Movie. Most of the 
time, though, this will be unnecessary. 

• MovieCaptioner will Undo/Redo on a caption by caption basis. You may also revert to 
the version that you originally opened during that session. A Temp folder will be created 
in your \user\AppData\Roaming\MovieCaptioner (Windows 7) or \user\Application 
Data\MovieCaptioner (Windows XP) folder for this purpose. All temp files will be deleted 
after you close your project. They will, however, be copied to the Backup folder under 
today’s date. These files are easily accessible from the MovieCaptioner File menu. 

• Special accented characters and symbols from the Symbols menu may not 
show up properly when you hit the Preview button. Instead, go to the Export 
menu and choose Embedded QuickTime (Unicode) or try changing your export 
preferences, depending upon the language your text is in. This is a limitation of 
QuickTime and not a result of any problem with MovieCaptioner. 

• If you create the QT SMIL format, you may find that when you play the QT .smi 
file, the audio may be garbled in the QT Player. This is a known bug in QT for 
Windows. It has been reported quite some time ago, but has never been fixed. 
There is a work-around, but must be done each time you open QT SMIL movies. 
To get it to sound right, go to the Window menu in the QT Player and select 
Show A/V Controls. Once that window opens, you can fix the sound by 
temporarily bumping the Jog Shuttle control (either way), then returning it to its 
normal state. It will magically fix the sound for some reason. I discovered this by 
accident. 

• SMIL-captioned movies may not display the text if the viewer's computer is set 
to a different language than what the SMIL captions are set to. So, if you are 
creating SMIL captions, set the language to what the target audience's computer 
language will be set to. This can be done in the Preferences window. You may 
need to create and link to different SMIL files to accommodate your audience's  
languages. 

• Using the option to change the timecode start time to 01: hours should not be 
used with embedded QuickTime. It should also only be used after setting all 
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captions. If you are exporting SCC for Final Cut Pro, then leave the start time at 
00: hours even if your movie starts at 01: hours.  

• The Undo option will not become disabled once the last undo has been used. It 
will instead change to “Cannot Undo”. 

• Some imported SCC files may not be synchronized properly once they are 
exported. This is due to differences in the way some software such as Final Cut 
Pro, QuickTime, and Compressor, for example handle the timing. If the file was 
made specifically for one of these, it may need a bit of nudging. Use the Shift All 
Start Times under the Edit menu if necessary to adjust how many seconds 
sooner or later the captions should begin. 

 

Getting Started 

 
Start by clicking on the Load Movie button. Browse your computer to find your 
movie. After loading your movie, you will be prompted to save your caption 
project. This is so that the automatic save feature can work properly and you 
won't need to remember to save your work. This could save you a lot of rework. 
Each time you enter a caption and either hit the Enter key or the Save Caption 
button, MovieCaptioner will automatically save your project. It will also save after 
editing a caption, or if you remove a caption using the Remove Caption button. 
Just make sure that when you save it initially you retain the ".mcp" extension on 
the project file. That way you can double-click it to launch your project. 

Please note that MovieCaptioner may make your movie aspect ratio look a bit off 
because it squashes it into a 320x240 player window. This is to maximize the 
caption interface space. This will not affect your movie at all. It will keep the same 
aspect ratio in the final version. In fact, MovieCaptioner will never change your 
original movie, unless you embed captions and save the changes in QuickTime 
Pro. 

After the movie is loaded and you've saved your project, the text area will then 
become active for editing. You will not be able to add text until a movie is loaded. 
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Click the Start button to start adding captions. Do not use the movie's play 
button! The movie's play button is there mostly to review the movie or if you 
need to skip over longer segments of the movie than the Repeat Interval allows.  

 
The Start/Stop Button 

 

After you click the Start button, the first 4 seconds (or 
whatever you have set in the Repeat Interval control) will 
begin repeating over and over until you type in what is being 
said and either hit the Enter key (preferred method) or click 

the Save Caption button. It will then go to the next four seconds (or whatever it's 
set to) and begin repeating that snippet.  If your movie will start out without a 
caption in the beginning, or at any point in the movie where nothing is being 
spoken, you can hit the Enter key or click the Save Caption button to save a 
blank text field for that section. Setting a blank caption is also a good idea if there 
is an extended period of time when no words are spoken. That way the previous 
caption will not stay on too long. 
If you find the repetition annoying, you can also start and stop the movie while 
adding captions by using the key combination CTRL+Spacebar. It will keep 
repeating while the Start button is on, but when Stop is clicked, CTRL+Spacebar 
will allow the movie to play through without looping. This might work similar to 
using a foot pedal for transcription. 

 
Controlling the Repeat Interval 
The Repeat Interval controls how long the loop sequence will be. It can be 
adjusted by clicking the arrows next to it to increment the interval or hitting the 
Control+Left or Right arrows. 

If you see that your caption is 
running to three lines, reduce the 
Repeat Interval and retype the 
caption. Try to keep your 
captions to two lines at most for 
best readability. 
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To skip larger parts of the, use the movie's Play button or drag to where you 
want the next caption to begin before clicking the Start button. A cue point will be 
set wherever you put the playhead. 

 
Overlap Button 

Sometimes a word can get cut off in the middle or not be heard at all when the 
movie is looping. If you're not sure you're hearing everything, you can click the 
Overlap button and it will add a second to the beginning of the interval loop. This 
should be enough to pick up any words that are getting cut off. You can deselect 
it by clicking it again when it says "Normal". It is not intended to be on all the 
time, but only when you need it. So it will automatically turn itself off once you 
save a caption. It will not affect the starting point of where the caption is to begin, 
but will merely let you hear a little more of the audio for clarity.  

 

Background and Text 

Although the default text size and font is a good start, you may use whichever 
size, font, and color you wish for each caption. You can only choose the 
Background color and text Background height once, since the same 
background will be used throughout the caption track. You can reset the 
Background color, Background height as many times as you want to get it 
looking the way you want, however. Checking the Translucent background 
button will put the text in the lower portion of the movie (not below it) with the text 
being laid over a translucent box. Note that the Background color pulldown 
menu is deactivated while in this mode, and that the Translucent background 
will not work in Preview mode, only in Embedded QuickTime exports. The 
Change All Captions button makes it much easier to experiment with how you 
want it to look. If you only want to change one or a few selected captions, use the 
Change Selected Caption(s) button instead of the Change All Captions 
button. SCC captions cannot have font properties applied to them. 

Note that the text properties of 
captions that have already been 
set will not change unless you click 
either the Change Selected 
Caption(s) button or the Change All 
Captions button! All new captions 
will automatically take on the 
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settings you have set in the Text Properties. 

 

Typing a pipe "|" character will force a line break in your caption for better 
readability. This also works when editing in the caption list. Although the pipe 
character will show in MovieCaptioner, it will not be displayed in your final export. 
It is used only as a marker for line breaks. Drag the vertical red line to the right to 
use as a visual guide as to where to put line breaks. See image below: 

 

Another easy way to add line breaks is to go to the Edit menu and select Add 
Line Breaks Automatically. You will be able to tell it how many characters wide 
each line of a caption should be. It will try to break the lines where there are 
spaces between words. If you are not happy with where they are breaking, you 
can just do it again. It will automatically remove all line breaks before doing it 
again. You can also remove all line breaks by selecting Delete All Line Breaks 
“|” in Caption List from the Edit menu. 

 

Saving Captions 
After you set your text in the text area, just hit the Enter key or click the Save 
Caption button to save the caption (Enter key is much faster). The caption will 
appear in the caption list on the right and the movie will advance to the next few 
seconds. Repeat this process throughout your movie. You can save a blank text 
area if you want the previous caption to disappear after it is read. Otherwise, the 
caption will be displayed in your movie until a new one is triggered. To set a 
blank caption at the end of your project to make the last caption disappear the 
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desired time, just hit the Save Caption button while there is no text in the text 
area where you normally type new captions. Once it adds a blank caption to the 
end, just change the timecode to suit your needs as compared to the caption 
before it. Make sure you don’t go past the movie’s Duration (displayed just above 
the top right corner of the movie).  

It is generally acceptable to change captions in mid sentence, so don't worry 
about trying to have complete sentences for each caption. You can to some 
extent control the look of your captions by typing a "|" character that will force a 
line break to even out your captions. The edit field where you type your captions 
is not always an accurate representation of what you will see on your final 
captioned movies. Preview your movies by clicking the Preview button to have a 
good idea of what your final captions will look like.  

Note that each time you set a caption, MovieCaptioner automatically saves your 
project. There is no need to save while you’re working. It will also save after each 
edit that you make to your captions. 

 
Editing Captions 

To edit any of your captions, just click into the caption you want to change in the 
caption list (on the right, not under the movie) and type over it. It’s best to edit in 
the caption list on the right instead of under the movie. This will prevent the 
edited caption from possibly being added as a new caption at the end of the list. 
Hit your Enter key to confirm the change after you’re done editing in the caption 
list. The whole row in the caption list should turn blue (as in the picture above) 
when the change is entered. MovieCaptioner will save the change automatically. 
Typing the pipe "|" character will insert a line break in your caption (see 
Background and Text above).  If you know how many characters wide you’d 
like to make your captions, you can move the red line to the right (by dragging 
the box on the bottom) to act as a visual guide so you can quickly go through and 
add forced line breaks. Use the Up/Down arrows to the left of the caption list to 
change the display size of the captions in the list. This will not affect the actual 
size of the exported caption text, however. It’s just for working in MovieCaptioner. 

Typing a paragraph tag "<p>" will cause the text to be broken up into paragraphs 
in HTML export and Transcripts (paragraph form). The paragraph tags will not be 
seen in other export formats. 

To edit a timecode, just click into it and change it. Please be sure to keep the 
proper formatting for the timecode! It should remain in this notation "hours : 
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minutes : seconds . hundredths of a second" - note the decimal between seconds 
and hundredths of a second. Straying from this format may cause errors in your 
timing, or it may not allow the captions to be added. After you are done editing 
the timecode, hit your Enter key to affect the change. MovieCaptioner will 
automatically reorder the rows if necessary. 

To remove a caption or captions, select its row in the caption list, and then click 
the Remove Caption button (or COMMAND+J). To insert a caption, click on the 
caption that you want your new caption to appear before, then click the Insert 
Caption button (or COMMAND+K).  MovieCaptioner will create a blank caption 
and give it a default timecode of about 1 second before the caption you selected. 
If no timecode is available it will default to 00:00:00.00.  Adding a blank caption 
between two timed captions will split the difference for the timecode between the 
previous and following captions. You may adjust the timecode as necessary by 
editing it directly in the caption list. Set your new caption as well by editing it in 
the list and hitting the Enter key to set the caption. 

To Split a caption into two captions, click into the caption you want to split, then 
insert the cursor between the words where you want the split to occur (as if you 
were going to type something between those words). Then click the Split 
Caption button (or COMMAND+L). Everything to the right of the cursor will be 
inserted into a new caption. MovieCaptioner will calculate the halfway point 
between the caption you are splitting and the following caption as the default for 
the caption that is split to a new row. Make sure you set the timecode properly for 
your new caption in the same format as the other timecodes. 

To move text from one caption to the next caption, click your cursor before the 
word you want moved, then click the Split To Next Caption button (or 
COMMAND+APOSTROPHE). All text from your caption after the cursor will be 
moved to the beginning of the next caption. This is especially helpful after 
importing text if you want to even out the captions or otherwise change the layout 
of the captions.  

To merge two consecutive captions click on the caption you want to be the first 
one, then click the Merge Captions button (or COMMAND+SEMICOLON). 
MovieCaptioner will take the second caption and add it to the first one that you 
selected, and will delete the second caption’s timecode as well.  

The captions can all be removed at once by selecting Delete All Captions in 
Caption List under the Edit menu. This is especially helpful if you import 
captions and decide you need to redo it for some reason. 
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Importing Transcripts  

 

All imported files must be plain text ".txt" files with no formatting, or you may get 
“gremlins”, stray characters that can goof up your project.  

If you have transcripts already in text format, you can import them into 
MovieCaptioner to create text tracks for your movies. If you have text that is in 
paragraph form or text that is set line by line with returns, you can import the text 
into MovieCaptioner by either selecting Import Text In Paragraph Form or 
Import Text in Line Form from the Import menu. Make sure your text files are in 
plain text (.txt) format and not RTF, PDF, MS Word or any other format that 
contains hidden characters or they will be imported along with the text. Use 
Notepad or some similar simple text editor. Just copy/paste your text into a new 
document and save it there as plain text with the “.txt” extension. You can control 
how many characters are distributed per each caption by going to the 
Preferences under the Help menu. If you plan on creating SCC captions, use 32 
as the maximum number of characters per line.  

 

You may also import Spruce STL caption files. This will automatically load the 
captions and their associated timecodes. The Spruce STL files must have a ".stl" 
extension to be recognized by MovieCaptioner. 

Text that is imported in paragraph form will automatically be separated into 
captions by sentence. To do this, MovieCaptioner will look for periods, question 
marks, and exclamation points to separate them by. If a sentence runs longer 
than 90 characters, MovieCaptioner tries to split it into two or more captions, 
looking for the space before the last word in the 90 character segment to 
separate the captions. 

Text may be imported in paragraph form as show below: 
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This is how the above text will import into MovieCaptioner: 

 

 

Text can also be imported in Line Form, such as these music lyrics below: 
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This is how the lyrics will import into MovieCaptioner: 

 

Text imported in line form will simply be separated by line. Each line will be a 
separate caption in the caption list. Blank lines will be skipped. Text can also be 
imported including timecode at the beginning, followed by a tab, then the caption 
(the same way MovieCaptioner creates transcripts with timecode below): 
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If properly formatted, the timecode will go into the appropriate field in the caption 
list. Note that whatever text and background properties that are set will be 
inherited for each caption. Other formats that can import timecode are STL, SUB, 
SRT, SCC, XML (timed text format), Adobe Encore, and SBV files from 
YouTube. Each of these has a separate option under the Import menu. 

The captions can be removed all at once by selecting Delete All Captions in 
Caption list under the Edit menu, or a few at a time by selecting captions and 
then choosing Remove Selected Caption(s) under the Edit menu. The Remove 
Caption button will do the same thing. 

Once the transcripts are imported, you may add the timecode simply by clicking 
the Set Timecode button that appears after importing a transcript as outlined 
below in Setting Timecode for Imported Transcripts. This button can also be 
made available by going to the View menu and selecting Show 'Set Timecode' 
button. You can use this to fine tune captions you set by typing as well. 

If special accented characters do not import properly, try going to the 
MovieCaptioner Preferences window and selecting a different Import Text 
Encoding.  

 

You might want to try opening your text file in a text editor to see what type of 
encoding it uses before selecting one from the pulldown menu. An easy way to 
do this is to open the file, then try to do a Save As. It will then display the default 
text encoding (such as UTF-8, for example). 
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Setting Timecode for Imported Transcripts 
Once you've imported your transcripts, setting the timecode for each caption is 
easy. After you import transcripts either in paragraph form or in line form, a “Set 
Timecode” button will appear at the top of the caption list.  

 

The Set Timecode button, when clicked, will begin playing the movie and will set 
timecode every time you click it. If the next caption does not get spoken before 6 
seconds passes, MovieCaptioner will automatically insert a blank caption so that 
the caption preceding it will expire. This is done so that if there is a long duration 
between spoken words in a movie, the captions won't need to be up the whole 
time. A blank caption will cause the previous one to disappear until the next 
caption appears. This option can essentially be disabled by putting a high 
number in for the expiration time. 

If there is no timecode imported with the text (as in the example above) the Set 
Timecode button will begin at the beginning of the movie, setting the timecode to 
"00:00:00.00".  The movie will continue to play and as each caption is spoken, hit 
your Enter key or press Set Timecode so that MovieCaptioner will set a caption 
cue at that time point in the movie. So, it's as easy as listening to the movie and 
pressing your Enter key whenever that caption is spoken. Once you've reached 
the end of your captions, it will stop automatically. Alternately, you can click the 
Stop button in the lower left under the Text Properties to stop setting timecode 
at any time. Note that if you make the MovieCaptioner interface wider, you'll be 
able to see the last words of each caption, which will help you anticipate the start 
of the next caption. You should attempt to hit the Enter key at the beginning of 
each caption as it is spoken. That caption will always be highlighted in blue as 
the one you are listening for. As soon as you hear the beginning of it, quickly hit 
the Enter key. 

Click the Stop button to stop 
setting timecode.    

If you already have some 
timecode set for some 
captions, and stopped for 
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some reason (by hitting the Stop button on the lower left), what you can do is to 
select the number for the last caption that has timecode, then click the Set 
Timecode button to resume setting timecode. What this will do is to tell 
MovieCaptioner to start at that timecode instead of at "00:00:00.00". Otherwise a 
blank timecode entry will trigger it to start at the beginning, and you wouldn't want 
that if you already have timecode set for 30 minutes of video, for example. So, 
just remember to select the last caption that has timecode before resuming with 
the Set Timecode button. See image below: 

 
To resume setting timecode after a stop, select the last caption that you have timecode for before 
pressing Set Timecode. 

This technique is also helpful if you want to fine-tune the timing that is set for a 
series of captions. For example, if you would like to reset the timing for captions 
26-30, first click on caption 25, then click the Set Timecode button to start 
retiming the captions. It will just overwrite the old caption timecodes. Alternately, 
you can fine tune all your captions by using the Set Timecode button and 
listening for each caption to be spoken, even if they were previously set using the 
Repeat Interval. The Set Timecode button is not limited to imported text, but 
can be used on any captions you have set to reset the timing if you wish. You 
can access the Set Timecode button at any time by selecting it under the View 
menu. It can also be used to retime the whole project after splitting the captions 
up into a more readable form. 

 
Shift Start Times 

If you can see that your captions are out of synch by a few seconds, you can go 
to the Edit menu and select Shift Start Times to adjust the number of seconds 
you want the captions’ timecodes to be offset. You can either have the captions 
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start sooner or later and you can either change all 
the captions or just the ones you have selected. 

If you are using DVD Studio Pro, you can add the 
Asset Start Timestamp to the timecode form in 
this window, then hit the Calculate button. It will 
compute the seconds needed to offset the 
timecode and automatically select Later. Clicking 
the Shift Start Times button will affect the 
change. 

 

 
 

Importing SCC  Format Files 
MovieCaptioner can import Sonic Scenarist (SCC) files. Choose this option from 
the Import menu. It will import the captions and timing from the SCC file. Note 
that the timecode you get from SCC files will be different from what is in the SCC 
file itself. This is because SCC format requires a buffer time depending on the 
length of each caption. MovieCaptioner will calculate the standard buffer time 
(one frame per 4-digit binary number of an SCC caption) and remove it, making 
the timecode appear slightly later than what is listed in the SCC file. This is 
normal and will make for more accurate synchronization for other caption formats 
that do not need the buffer time. Exporting to SCC will add this standard buffer 
time back in. 

 

Importing QuickTime Text Files 

MovieCaptioner can import the timecode and captions from a QuickTime text file. 
It will not currently import font styling, so set your text properties the way you 
want them set before importing the QuickTime text file. 

 
Importing CART Files 
CART (Communication Access Realtime Translation) files must be in plain text 
(.txt) format to import properly. They can either import as text with timecode or 
just plain text, depending on the file you import. 
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Previewing Your Work and Creating the Final Text Track 
You can preview your captions by clicking 
the Preview button. This will launch the 
Preview window so you can view the text 
track in the movie. Just play the movie to 
view your work so far. If you're all done 
with your captions and it looks okay in 
Preview, you can use the Save As button 
on the Preview window to save it as an 
embedded QT Text movie. This would be 
the same as the first option under the 
Export menu. 

If you still need to do some editing, close 
the Preview window and continue on with 
your editing. Note that the Preview 
window does not do a live update and the 

latest changes can only be seen after clicking the Preview button. Preview your 
captions from time to time until you get a good feel for how much text you can 
add for any one caption with the particular font and size you are using and how 
large you need to make the background for the text. 

Please note that previewing with the Preview button will not always display some 
characters with accents. If, for example, you've imported Korean text or certain 
symbols into the caption list, use the Embedded QuickTime (Unicode) export 
option to see your captions. Just don't save the embedded captions if you wish to 
do further editing.  

 

Changing the Location of a Text Track 
You may change the location of the text track to either below the movie or to be 
covering the bottom portion of a movie (whatever you have chosen as the text 

background height). Click on the 
Change Text Track Location 
under the Edit menu to select 
one of these two options.  

Using the second option may be 
a better choice if you decide you 
want to create open captions for 
a DVD, for example. To do this, 
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select "Put captions in the bottom portion of the movie", then Export as 
Embedded QuickTime. After the captions are embedded, you will need to export 
the movie again to "burn" the captions into the video track so that they are visible 
at all times. Export as the highest quality DV file. Then you can import your video 
into iMovie to burn a DVD using iDVD.  

An even better option would be to click the Translucent Background option in 
the Text Properties area. This will put the captions over the bottom portion of the 
movie, but they will be over a translucent background so you can still see the 
movie through it, but the text will be easy to read. Checking the Translucent 
Background option overrides any text track location settings that you may set. 

You may also change the text location via the Preferences window. 

 

Undo, Redo, and Revert To Previous Version 

The Undo and Redo under the Edit menu works on a caption-by-caption basis. 
Once a caption is set it is automatically saved. You may Undo and Redo to the 
previously saved caption as long as you have your project window open. Once 
you make a change, however, you will no longer be able to Redo. A Temp folder 
will be created in your MovieCaptioner folder in your Application Support folder 
where all the scratch files will be saved. These will be deleted when you close 
your project. Before they are deleted, however, they will be copied to a Backup 
folder one directory up from the Temp folder. These can be accessed from the 
File menu (Open Backups Folder option) should you need to revert to an earlier 
version for some reason. They will be saved by date in the Backups folder. 

When you open a project you’ve worked on before, the Revert to Previous 
Version option under the File menu becomes enabled. If you choose this, it will 
revert to the state it was in when you first opened it during that session. So if you 
make a bunch of changes, then decide that you don’t want to keep them, you can 
go back to the way it was when you first opened the project. This option is not 
available for new projects as that would basically blank out all the captions. The 
Revert option is handy if you want to reformat your captions for a specific export, 
but don’t want to keep it that way in the long run. This might have to do with the 
way captions are broken up, perhaps, for some export formats. 

 

 

 



	
   20	
  

Backups Folder 

A Backups Folder can be found in the user’s AppData\Roaming\MovieCaptioner 
folder (Windows 7) or Application Data\MovieCaptioner folder (Windows XP). 
This folder is easily accessible from MovieCaptioner’s File menu. Choose the 
Open Backups Folder option. 

 

Open the folder with the date that you created the project and you will find up to 
ten project versions. Selecting the version with the highest number appended to 
the name will usually give you the latest version. It might actually be the date 
when you first closed the project as well, as this is when the files are copied to 
the Backups folder. When you close a project, any files in the Temp folder will be 
copied over to the Backups folder, so if MovieCaptioner were to crash and when 
you reopened it, you didn’t see your last changes, you might be able to open one 
of these files to get one of the most recent versions. The files will be copied to a 
folder under the date when they were copied (not necessarily created). When 
you open MovieCaptioner, if it sees that there are files in the Temp folder, it will 
automatically copy these files over to the Backups folder. It will assume that for 
some reason MovieCaptioner crashed and could not backup these files the last 
time it was open. This is (hopefully) a fail-safe way of not losing hours worth of 
work. Using some other automatic backup system is also a good work practice 
for anyone and is highly recommended. 

 
Export Formats 
If you are exporting text from a language that uses special accented characters, 
you may need to go to the MovieCaptioner Preferences window and select a 
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different option from the Export Text Encoding pulldown menu. That may help if 
you get garbage characters where these characters should be. This may require 
some trial and error to get right. Eporting as Embedded QT (Unicode) can often 
support many accented characters without changing the export encoding 
preferences, however. 

 

Creating Embedded QuickTime Text Captions 
When you are all done with setting your captions, select the Embedded 
QuickTime option under the Export menu or the Save As button in the Preview 
window. MovieCaptioner will automatically embed the captions and ask you to 
save the movie as a new file (keeping your original movie unchanged. Please 
note that QuickTime Text Tracks (which the Embedded QT option uses) do not 
support accented characters very well. To get around this, use the Embedded 
QuickTime (Unicode) export option. It uses XML instead of QT Text tracks. 

 

Creating a QuickTime SMIL Captioned Movie 
I would like to mention that at some point in QuickTime for Windows’ version 
history, QT SMIL has had a bug that Apple never fixed. When the movie plays, 
the sound gets garbled pretty badly. The only fix I have discovered is that you 
can open the QuickTime Player’s A/V Controls window and slightly change the 
Jog Shuttle, Pitch Shift, or Playback Speed and the sound will be restored to 
normal. However, this must be done each time a QT SMIL movie is opened and 
cannot be set as any type of preference. Apple has known about this bug for 
years and has never fixed it. For this reason, I would not recommend using the 
QT SMIL export for use on Windows computers. If you still need to create this 
format, however, or if Apple somehow fixes this, you may read on. 

When you are all done with setting your captions, select the QuickTime SMIL 
option under the Export menu. MovieCaptioner will create two files, one with a 
".txt" extension, and one with a "qt.smi" extension.  It will then launch the file with 
the ".qt.smi" extension in the QuickTime Player. If uploading this to a server, 
make sure you keep all three files in the same directory or it will not work. So, the 
".mov" file, the ".txt" file, and the ".qt.smi" file should all be together. Make any 
links you have to the ".qt.smi" file. This file will in turn reference both the ".mov" 
file and the ".txt" file to display the captions. If you see a blank box with the name 
of the language ("English" for instance) below the movie, it usually means there 
is some timecode that is not in proper order or it could mean that it could not 
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write the text files to the same directory as the movie. Adjust as necessary then 
try again. 

If you use the Translucent background option, there will be still another file to 
keep with your .txt, .qt.smi, and your .mov file. It will be called “bkgd.txt”. This is 
the translucent background track that is used behind the text. 
 

Creating a Flash XML File 
Flash has the ability to link to an XML file for the purpose of displaying captions. 
MovieCaptioner will create this file for you when you click the Flash XML button. 
You must use a QuickTime movie to create your captions on the Windows 
version of MovieCaptioner. On the Mac version, you may use FLV files, since 
there is a plugin for QT that allows this on the Mac. Since the timing is all you 
need, a QT movie will work fine as long as its timecode is identical to that of the 
target FLV file. 
The XML file will be saved to your hard drive (in the same folder as your movie) 
calling it "captions.xml". To use this file, launch Flash (CS3 or newer) and create 
a new Actionscript 3.0 Flash file into which you will import your movie. You don't 
need to add any cue points. The XML file will do that for you. Select a skin that 
contains the words "Play" and "Caption". In this example I'm using 
"SkinUnderPlayCaption.swf". After importing your movie, go to the Components 
window (under the Window menu) and select the FLVPlaybackCaptioning 
component and drag a copy of it to the stage (don't worry, it will be invisible). See 
image below. 

Once you've done that, click on this component on the stage, and go to the 
Components Inspector window (under the Windows menu again). While the 
component is still selected, click on the Parameters tab in the Component 
Inspector window and change the Source parameter to the XML file that 
MovieCaptioner created. Test your Flash movie by publishing it. You should 
always keep the XML file with this Flash movie.  
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Creating YouTube Captions 
Selecting this option will create a .SRT formatted file which you can upload to 
YouTube. Once you export this file, go to your movie’s page on YouTube and 
select the Edit captions/subtitles tab at the top of the page.  

 
Next, click the Add New Captions or Transcript button. 

 



	
   24	
  

Then just use the Choose File button and locate the .SRT file on your hard drive, 
make sure Caption file is selected, then hit the Upload file button. Your captions 
should display the next time you view your movie. 

 

Note: If you do not like the way YouTube displays your captions (sometimes they 
may have a long line then one word on the second line) you can adjust it by 
adding carriage returns to your SRT file in a plain text editor. Just watch your 
video as the captions appear and stop it when you see one you do not like. Use 
carriage returns to break up the text to a more orderly display and save your SRT 
file. Before re-uploading your SRT caption file, use the Remove button on the 
YouTube interface to delete the previously uploaded caption file. 

 

 
Creating JW Player Timed Text (TT) Files 
Select this option if you want to create captioned text files to be used with the JW 
Player. More information about this player and how to make your videos 
accessible with it can be found at http://www.longtailvideo.com and 
http://www.longtailvideo.com/addons/plugins/84/Captions?q=. 

http://www.longtailvideo.com/addons/plugins/84/Captions?q=
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Creating Common Look and Feel Player Timed Text (TT) Files 
Select this option if you want to create captioned text files to be used with the 
Common Look and Feel (CLF) Player, a multimedia standard in Canada. More 
information about this player and how to make your videos accessible with it can 
be found at:   http://www.tbs-­‐sct.gc.ca/clf2-­‐nsi2/tb-­‐bo/td-­‐dt/gcttg-­‐gtmgc-­‐
eng.asp#cn_10.3_mpjm 

 

Creating Adobe Encore Caption Files 
Select this option if you want to create captioned text files to import into Adobe 
Encore's DVD-making software. 
 

Creating Sonic Scenarist (SCC) Caption Files for iPods, 
iPhones, and Broadcasting 
Select this option if you want to export SCC format closed caption files that can 
be used on iPods, iPhones and in broadcasting (Line 21 captions). Note: Apple 
has not created the ClosedCaptionImporter.component plugin for Windows, so 
this file can only be embedded into a QT movie using a Mac computer. The SCC 
file can, however, be used for other applications that can use this format, such as 
Adobe Premiere. 

By default, all captions are set to the bottom (Row 15). A two-line caption will 
automatically start on Row 14, a three-line caption will start on Row 13, and a 
four-line caption will automatically start on Row 12, even though Row 15 may be 
selected. You may only have 4 lines in any given caption and each line has a 32 
character limit. This is the spec for SCC captions. Luckily, MovieCaptioner 
figures all this out for you and breaks up the lines where it can between words at 
the 32 character limit and will warn you if any caption goes over the 4 line limit. 
MovieCaptioner will run two passes on export to check each line for length and 
add the pipe "|" symbol where necessary to break up lines. You may want to 
remove any pipe symbols that you have previously and let MovieCaptioner do it 
for you. It tends to work better that way. You can do this easily by going to the 
Edit menu and selecting Remove All Line Breaks “|”. Try this if you see that 
some of your captions are getting truncated. Then export as SCC again. If this 
will affect other export formats, then you may want to create an SCC-only version 
of your project or use the Revert to Previous Version option after you’re done 
exporting as SCC. If it suddenly gives you an error saying there are too many 

http://www.tbs-sct.gc.ca/clf2-nsi2/tb-bo/td-dt/gcttg-gtmgc-eng.asp#cn_10.3_mpjm
http://www.tbs-sct.gc.ca/clf2-nsi2/tb-bo/td-dt/gcttg-gtmgc-eng.asp#cn_10.3_mpjm
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lines in a particular caption, try removing all the line breaks and exporting again. 
That usually clears up that problem. 

You may control which SCC row each caption starts on by selecting a caption’s 
number in the list of captions, then selecting the Row number (1-15) in the SCC 
Row pulldown menu. Then click the Change button to set the row. When a 
caption is clicked on in the caption list on the right, its SCC row will be displayed 
in the SCC Row pulldown menu. You may also set the SCC Row pulldown, then 
go to the Edit menu and choose Change All SCC Rows To Current Selection 
to change all captions to start on that row. 

  
Selecting Sonic Scenarist (SCC) from the Export menu will only create the SCC 
text.  

The SCC format buffers the captions before displaying them, so MovieCaptioner 
will calculate the required buffer time and move the timecode up accordingly to 
allow the captions to show up at the proper time. Otherwise they will come up a 
second or two too late for the video. So, bear this in mind if you see that the 
timecode in the resulting SCC file is different from what you see in 
MovieCaptioner. This is normal and will result in more accurate synchronization. 

At this time, MovieCaptioner can only put the SCC centered, left justified. SCC 
captions can have no more than 32 characters (including spaces) per line of 
captions, and only 4 rows can be visible at a time.  
Tip: If you are importing text, it would be best to set your text import settings to 
no more than 64 characters in the MovieCaptioner Preferences window if you 
know you will be exporting as SCC. On export, MovieCaptioner will check each 
caption and put line breaks into any caption that is longer than 32 characters 
automatically. If there are more than 4 lines of text, MovieCaptioner will stop the 
export and notify you as to which caption is too long. You must shorten that 
caption by either removing  characters or splitting the caption up into two 
captions. You should also try to keep SCC captions at least a couple seconds 
apart to prevent overlap errors, which can be common to the SCC format. 

Once you have the .SCC file, you can import this into Adobe Premiere or Final 
Cut Pro 7, for example, and create line 21 captions. You should use the 00 HR 
Start Time (under the Edit menu) if going to Final Cut Pro 7 as Final Cut handles 
the time relative to the start of the clip. If adding bars and tone in Final Cut, you 
should use the Shift All Start Times by the number of seconds of your bars and 
tone. It’s best, though, to have the bars and tone on a low res version of the 
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movie that you use only in MovieCaptioner just to get the timing and captions 
right.  

Some software may require you to have the timecode starting at 01 hours. You 
can do this by going to the Edit menu and selecting Timecode to 01 HR Start 
Time. Use this only after making sure your caption timing is all set, as in the case 
with SCC captions, where you will probably need to shift the start times of the 
captions using the Shift All Start Times option under the Edit menu.  

If you export as SCC format and instead of seeing captions you see a black 
screen with "Sonic Scenarist V1.0", you probably have an issue with timecode in 
your project. Make sure all timecodes are in sequence and preferably at least 
one second apart to give the player  enough time to buffer the next captions. 
Otherwise they could be skipped. Another reason could be a stray character 
(such as a bullet) is in the binary numbers that represent the captions. Make sure 
each line of the SCC file has letter/number combinations that are 4 characters 
long. Anything else (like 3) will cause errors. See this blog post for 
troubleshooting SCC files: 
http://synchrimedia.blogspot.com/2011/06/troubleshooting-scc-line-21-
caption.html             

A helpful application to own if you’re doing a lot of SCC 
caption work is SCC Caption Decoder for Windows. It 
will turn the code into readable text so you can 
troubleshoot errors in your SCC caption file easier. 

You can find SCC Caption Decoder here: 
http://www.synchrimedia.com 

 
 

Creating Spruce STL Caption Files 
Select this option if you want to create captioned text files to import into Apple's 
DVD Studio Pro software. Note that STL files may also be imported into 
MovieCaptioner. This might be done possibly to create a caption track in another 
language, for example.  

 

Creating SRT and SUB Files for YouTube or DVD Software 
Select SRT or SUB if you would like to create files compatible with YouTube, or 
DVD software. See instructions above for creating YouTube captions. 

http://synchrimedia.blogspot.com/2011/06/troubleshooting-scc-line-21-caption.html
http://www.synchrimedia.com
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Creating SAMI Files 
SAMI files are caption text files that are used with Windows Media Player. 
Unfortunately, MovieCaptioner cannot yet use Windows Media or AVI movies. 
You must first convert your movie to a QuickTime format to use with 
MovieCaptioner. As long as the name is the same (except for the extension) and 
the timecode is exactly the same as the WMV file, you’ll be able to create the 
SAMI files necessary to use with your WMV movie. 
Upon choosing the SAMI File export, MovieCaptioner will create 2 files: One will 
have a ".smi" extension and the other will be a ".asx" file. The “.asx” file will be 
unnecessary if your “.smi” file has the same name as your movie (other than the 
extension). Windows Media Player will know to use the “.smi” file for captions if 
you select the option to show captions in the Windows Media Player. 

Otherwise the “.asx” and “.smi” must always be located in the same folder as 
your Windows Media movie or they will not play. The ".asx" file is the file you will 
load into the Windows Media Player. It will join the caption file (.smi) with the 
movie file to synchronize the text with the movie. There is still another step, 
however, if you plan to use them online. 

If you will be uploading the files to your server for people to view online, you will 
need to make a change to the “.asx” file. For some reason, Windows Media may 
not play the files properly unless you use an absolute URL to the two files. So, for 
example if my SAMI files are uploaded to the following folder on my server:  
http://www.myserver.com/movies/, then I know to change the line referring to 
these files in the asx file to:                  

<ref href="http://www.myserver.com/movies/mymovie.wmv?sami= 
http://www.myserver.com/movies/mymovie.smi" /> (all on one line) 

Prior to my changing it, the line would have looked like this:                                

 <ref href=”mymovie.wmv?sami=mymovie.smi” /> 

By default, the Windows Media Player does not display captions. You will need to 
select "Show Captions and Subtitles" from the Play menu in Windows Media 
Player on Windows to see your captions if they do not appear. There is also a 
similar setting in the Preferences under the Security tab you may also need to 
set.  Also, captions may not look right when viewed with Windows Media Player 
on a Mac. The Mac version of Windows Media is not very good. Try your SAMI 
files on a Windows machine before concluding that there are problems. You can 
get away with not using the “.asx” file as long as the “.smi” file has the same 
name as your movie. Windows Media will automatically associate it with the 
movie in that case. 
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Some special characters may not display correctly in the Windows Media Player. 
If this occurs, try opening the “.smi” file in Notepad and saving it as an ANSI text 
file. For some reason this works. ANSI must support a wider character set than 
standard Unicode. 

Creating WMP Text Files 

WMP text files are a little-used, but excellent method of embedding captions into 
a Windows Media Player video. MovieCaptioner will make the text file for you. 
From there you will need to use something like Windows Media Encoder 9 to 
embed the WMP.txt file into the movie. This is handy because the movie and 
captions will be self-contained in one file instead of up to 3 files as in SAMI 
captions. Within the Windows Media Encoder, there is a utility called Windows 
Media Editor, which will allow you to embed the text captions into the movie as 
one file.  

HTML5/Timesheets  

This is an adaptation of the SMIL/Timesheets solution created by Fabien 
Cazenave. More information can be found at this website: 
http://wam.inrialpes.fr/timesheets/annotations/video.html. Choosing this option 
will create and launch an HTML5 web page with the video embed code written 
for all three HTML5 supported video formats: MP4, OGG, and WEBM. 
MovieCaptioner will not export these different video formats, so you will need to 
create all 3 video formats of your movie to ensure that your video will be visible 
on major browsers that support HTML5 markup. Please refer to the HTML5 web 
page created by MovieCaptioner to make sure you name the movie properly, or 
you can just change the HTML5 markup accordingly. What you choose for the 
background color will become the background color of the Web page. 

                  
HTML5/Timesheet Captions as seen in the browser  

http://wam.inrialpes.fr/timesheets/annotations/video.html


	
   30	
  

MovieCaptioner will write the HTML5 Web page called “timesheet.html” and also 
a file called “timesheets.js”. Both of these files will be written to the same folder 
as your movie on your hard drive. Be sure to include these files with your movie 
when uploading to your Web site. 

Creating Text Transcripts 
By using one of the transcript export options, MovieCaptioner will save all your 
captions into one succinct text file, in either paragraph form where all text is 
compiled into a paragraph, or in timecode form where each caption's timecode is 
listed next to the caption and a space is put between lines. This type of transcript 
makes a good backup of your project as well, as it can be imported with timecode 
intact.  

If you have accented characters in your captions that do not appear properly 
once exported as transcripts, try changing your MovieCaptioner export 
preferences to another option. 
Typing a paragraph tag "<p>" will cause the text to be broken up into paragraphs 
in HTML export and Transcripts (paragraph form). The paragraph tags will not be 
seen in other export formats. 
And, if you are going to identify speakers, MovieCaptioner will automatically put 
an extra space every time it sees a "[" character to make the transcripts more 
readable like a movie script. For example if you have two people talking in your 
movie or podcast, and you use the convention: 
[ person's name ] What they said. 
Your transcript will be written with a space between each speaker's lines: 
[ Bill McCoy ]  Hello, welcome to this week's podcast. 

[ Frank Adams ]  Yes, Bill, we have a great show lined up for you today. 

Another advantage of creating a transcript of your captions is that you can then 
easily take it into Microsoft Word or a similar text editing s/w and do a spell check 
and set any formatting that you like to the document. 

 

Creating HTML Transcripts 
By clicking the HTML option, MovieCaptioner will save all your captions into a 
web page, separating it by paragraphs if you use paragraph tags "<p>" in the 
captions. Note that other export options will ignore the <p> tags, so you don't 
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have to worry about them showing up in your embedded QuickTime captions, for 
example. Again, if you have accented characters that do not appear properly, try 
changing your MovieCaptioner export preferences to another option. 
 
Setting Your Preferences  
If you want MovieCaptioner to open new projects with a certain font, size, style, 
and color as the default, go to the Help menu and choose "Preferences...". 
There you can set your text preferences as well as your 

background color, background 
height in pixels, background 
translucency, Repeat Interval, 
and whether or not you want the 
reminder to come up when using 
the Preview button. Note that 
changing the preferences will not 
affect your current project, but 
rather it will set the default for all 
new projects. The checkbox for 
Translucent background will 
take effect immediately, 
however, once you click the 
Save Preferences button. You 
may also set the maximum 
number of characters that each 
caption will have when importing 
text into MovieCaptioner. Setting 
the language is important for 
both SMIL and Flash XML 
captions. This would be 
referencing the target computer's 
language setting (not the 

keyboard setting). If you have a text file that you know is saved in another format, 
you can set Import Text Encoding to that format before importing to prevent 
importing garbage characters. Likewise if you are exporting text with special 
accented characters, you may need to use another option from the Export Text 
Encoding pulldown menu. The Frames Per Second pulldown menu allows you 
to select your movie’s timecode format for exporting STL and Encore formats.  
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Troubleshooting and Misc. Wierdisms 
MovieCaptioner works best if you work with both the movie and the project file on 
your main hard drive. This will eliminate problems with auto-saving, writing 
caption files, and performance issues in most cases.  

If MovieCaptioner crashes when you import a file, check your MovieCaptioner 
Preferences window to see what the Import Encoding is set to. In most cases 
UTF-8 is the best choice, but your file may require a different one. 

It is also best to not use movies with a frame rate of higher than 30 frames per 
second as they can bog down MovieCaptioner and cause it to stutter at some 
point. If necessary, you may substitute the higher frame rate version of the movie 
after you are done creating captions by going to the File menu and selecting 
Load Movie. Most of the time, though, this will be unnecessary. 

Sometimes imported or pasted garbage characters can interfere with your project 
file, preventing it from opening. Try setting the MovieCaptioner text import 
preferences to another option, or you can try opening it in a text editor and saving 
the file as UTF-8 if possible.  

Also, make sure that you can write to the directory where the movie is stored. 
Keeping the movie on a DVD or CD will prevent MovieCaptioner from being able 
to write the caption text file that is uses to import the captions into QuickTime. Try 
saving a copy of the movie to the Desktop and using that one in your project 
instead. 

Another reason for the failure of QuickTime to launch could be that there is a 
timing conflict with some of your captions, i.e., there may be caption occurring at 
00:05:03 and the caption following it may be the exact same time or at a previous 
time like 00:05:01. This shouldn't really happen, but if it does it will confuse 
QuickTime, so the track will not be added. MovieCaptioner will auto-check your 
timecode to see if any rows are out of sequential timecode order, but there is the 
possibility that it may miss something.  If any are out of order, just change the 
timecode so they will appear in order. If it still will not work, try deleting and 
resetting those captions. Another option would be to export as one of the import 
options such as Transcripts (with timecode) and after creating a new project, 
import as Text In Line Form. You should probably delete the first line (the title of 
the movie) in the transcript before importing, however, or it will come in as the 
first caption. Doing this will often fix corrupted projects that won’t export properly, 
and is a good project backup strategy as well.  

Remove any unnecessary tracks (anything other than a standard video and 
audio track) in your movie using QT Pro, and save the movie before attempting 
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to add the captions. If there are other tracks, you must open the movie in 
QuickTime Pro, go the Movie Properties window, then select and delete each 
extra track. 

If you imported text and it does not appear in the caption list as it should, you 
may have selected the wrong format (paragraph form or line by line form). Note 
that these imported text files must be text-only (not RTF or MS Word and no 
photos or other types of formatting). 

Make sure your movies have a video track and a sound track and not a single 
muxed track that you get with MPEG-1 and MPEG-2 videos. A muxed track will 
cause issues when you go to embed captions. You can tell by opening the movie 
in QT Pro and selecting the Show Movie Properties window. If you have a single 
muxed track, you will need some s/w such as MPEG StreamClip to break it up 
into separate audio and video tracks. 

If you export as SCC format and instead of seeing captions you see a black 
screen with "Sonic Scenarist V1.0", you probably have an issue with timecode in 
your project. Make sure all timecodes are in sequence and preferably at least 
one second apart to give the player  enough time to buffer the next captions. 
Otherwise they could be skipped. Another reason could be a stray character 
(such as a bullet) is in the binary numbers that represent the captions. Make sure 
each line of the SCC file has letter/number combinations that are 4 characters 
long. Anything else (like 3) will cause errors. See this blog post for 
troubleshooting SCC files: 
http://synchrimedia.blogspot.com/2011/06/troubleshooting-scc-line-21-
caption.html             

A helpful application to own if you’re doing a lot of SCC 
caption work is SCC Caption Decoder for Windows. It 
will turn the code into readable text so you can 
troubleshoot errors in your SCC caption file easier. 

You can find SCC Caption Decoder here: 
http://www.synchrimedia.com 

 
 
Your Input is very Important! 
Please help me to improve MovieCaptioner. Let me know what you like and what 
you dislike about MovieCaptioner. Most all of the changes in this version of 
MovieCaptioner were a direct result of user comments. If you have any ideas or 

http://synchrimedia.blogspot.com/2011/06/troubleshooting-scc-line-21-caption.html
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things you'd like MovieCaptioner to be able to do, please contact me at 
support@synchrimedia.com. But, please be patient with me. I'm not a "real" 
programmer, but I will try to help if I can. 
Thank you for using MovieCaptioner!  

mailto:support@synchrimedia.com?subject=MovieCaptioner Feedback

